martes, 14 de febrero de 2012

Resolver error alsa-utils-1.0.25-7 fedora 16



El dia hoy 14 de febrero me encontre con este lindo error al querer actualizar fedora. Algunos pueden tener problemas con el audio en algunos casos.

¿A que se debe esto?

Aun lo desconozco y  he encontrado el bug reportado
https://bugzilla.redhat.com/show_bug.cgi?id=790474



[root <at> kubb ~]# yum update
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package alsa-utils.x86_64 0:1.0.24.1-5.fc16 will be updated
---> Package alsa-utils.x86_64 0:1.0.25-7.fc16 will be an update
--> Processing Dependency: alsa-lib >= 1.0.25 for package:
alsa-utils-1.0.25-7.fc16.x86_64
--> Finished Dependency Resolution
Error: Package: alsa-utils-1.0.25-7.fc16.x86_64 (updates)
           Requires: alsa-lib >= 1.0.25
           Installed: alsa-lib-1.0.24-2.fc15.i686 (@fedora/15)
               alsa-lib = 1.0.24-2.fc15
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


Igual sucede en versiones de 32 bits




 

¿Como lo solucionamos?




su -c 'yum --enablerepo=updates-testing update alsa-utils' 




Lo anterior instala  alsa-utils-1.0.25-7 desde los repositorios testing, pero para quien tenga problemas o quiera actualizar sin problema puede usarlo.



Otras formas


Ignorando paquetes que den conflicto


Esto no lo arregla, simplemente ignora las actualizaciones que presenten conflicto con este error, :(


su- c 'yum update --skip-broken'
Reacciones:

0 comentarios:

Publicar un comentario en la entrada

Si comentas te pedimos por favor respeto y críticas constructivas referentes al título del articulo. Cualquier comentario para desviar el tema, spam o trolleo no será permitido. Gracias por comentar.