martes, 1 de octubre de 2013

¿Extrañas tus juegos de Nintendo 64? Mupen64Plus en Fedora y Ubuntu





Llegan tiempos donde muchas veces queremos recordar aquellos juegos no tan educativos en la vida de un gamer, si usted es del clan, sepa que no esta solo. Lejos asuntos como buscarse a si mismo, paranoia con la NSA o la paz interior...

Hemos creado paquetes de Mupen64Plus para Fedora, de modo que usted pueda darle la oportunidad y revivir por un ejemplo un "Fatality" o saltar por todos lados con nuestro amigo bigoton y su hermano Luigi...



Pero... ¿Qué demonios es Mupen64Plus?

Mupen64 "Multi-Platform Emulator for the N64" (Emulador multiplataforma para N64) es un emulador de la consola de videojuegos Nintendo 64.

Mupen64 se desarrolló originalmente en y para sistemas GNU/Linux, pero está diseñado para ser multiplataforma. Ha sido portado a otros sistemas operativos utilizando la biblioteca SDL, incluyendo Microsoft Windows, BeOS, Mac OS X, y FreeBSD. Mupen64 es software libre, publicado bajo los términos de la Licencia Pública General de GNU.

Mupen64 conoció la popularidad después de que el sitio web Goldeneye Forever utlizó su funcionalidad en línea para iniciar torneos.


INSTALACIÓN


Fedora

su

32 bits

yum -y install http://sourceforge.net/projects/postinstaller/files/fedora/releases/19/i386/updates/mupen64plus-2.0-4.fc19.i686.rpm

Plugins extras

yum -y install http://sourceforge.net/projects/postinstaller/files/fedora/releases/19/i386/updates/mupen64plus-extraplugins-2.0-4.fc19.i686.rpm


64 bits

yum -y install http://sourceforge.net/projects/postinstaller/files/fedora/releases/19/x86_64/updates/mupen64plus-2.0-4.fc19.x86_64.rpm

Plugins extras

yum -y install http://sourceforge.net/projects/postinstaller/files/fedora/releases/19/x86_64/updates/mupen64plus-extraplugins-2.0-4.fc19.x86_64.rpm




Ubuntu

AQUI




M64Py


http://m64py.sourceforge.net/

Es un front-end (GUI) para Mupen64Plus 2.0, un plugin basado en el emulador de Nintendo 64, multiplataforma.  

Este Front-end está escrito en Python y proporciona una interfaz fácil de usar a través de bibliotecas compartidas de Mupen64Plus. Se necesita tener instalado Mupen64Plus. 

Con este front-end usted se olvidara de utilizar la terminal y configurar las opciones y correr las roms con Mupen64Plus de manera fácil. 

Instalación de M64py


Fedora

su

yum -y install http://sourceforge.net/projects/m64py/files/m64py-0.1.6/m64py-0.1.6-1.noarch.rpm

Ubuntu

wget -c http://sourceforge.net/projects/m64py/files/m64py-0.1.6/m64py_0.1.6-1_all.deb

sudo dpkg --install m64py_0.1.6-1_all.deb




Referencias:
http://es.wikipedia.org/wiki/Mupen64 
Reacciones:

9 comentarios:

  1. No me corre, me lanza un poco de problemas:

    [root@localhost edusandovall]# m64py
    Qt: Session management error: None of the authentication protocols specified are supported
    __ __ __ _ _ ____ _
    | \/ |_ _ _ __ ___ _ __ / /_ | || | | _ \| |_ _ ___
    | |\/| | | | | '_ \ / _ \ '_ \| '_ \| || |_| |_) | | | | / __|
    | | | | |_| | |_) | __/ | | | (_) |__ _| __/| | |_| \__ \
    |_| |_|\__,_| .__/ \___|_| |_|\___/ |_| |_| |_|\__,_|___/
    |_|

    M64Py - A frontend for Mupen64Plus version 0.1.6

    Frontend: INFO: ScreenSaver not available: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    ldd: warning: you do not have execution permission for `/usr/lib/libmupen64plus.so.2.0.0'
    Frontend: INFO: attached to library 'Mupen64Plus Core' version 2.0.0
    Frontend: INFO: includes support for Dynamic Recompiler.
    Frontend: INFO: video extension enabled
    Input: Missing or incompatible config section 'Input-SDL-Control1'. Clearing.
    Input: Missing or incompatible config section 'Input-SDL-Control2'. Clearing.
    Input: Missing or incompatible config section 'Input-SDL-Control3'. Clearing.
    Input: Missing or incompatible config section 'Input-SDL-Control4'. Clearing.
    Audio: No version number in 'Audio-SDL' config section. Setting defaults.
    Traceback (most recent call last):
    File "/usr/bin/m64py", line 76, in
    main()
    File "/usr/bin/m64py", line 61, in main
    window = MainWindow((opts, args))
    File "/usr/lib/python2.7/site-packages/m64py/frontend/mainwindow.py", line 72, in __init__
    self.worker.init()
    File "/usr/lib/python2.7/site-packages/m64py/frontend/worker.py", line 50, in init
    self.plugin_load_try()
    File "/usr/lib/python2.7/site-packages/m64py/frontend/worker.py", line 109, in plugin_load_try
    self.m64p.plugin_load_try(plugins_path)
    File "/usr/lib/python2.7/site-packages/m64py/core/core.py", line 226, in plugin_load_try
    plugin_handle = C.cdll.LoadLibrary(plugin_path)
    File "/usr/lib64/python2.7/ctypes/__init__.py", line 438, in LoadLibrary
    return self._dlltype(name)
    File "/usr/lib64/python2.7/ctypes/__init__.py", line 360, in __init__
    self._handle = _dlopen(self._name, mode)
    OSError: libboost_filesystem-1_49.so.1.49.0: cannot open shared object file: No such file or directory

    ResponderEliminar
  2. Muchas gracias por empaquetarlo tengo un mes tratando de instalarlo en mis ratos libres pero el sh que trae no da para fedora 19 :( y tampoco me funcionama el m64py , logre correr el zelda pero todo por consola y eso no ,pifa,no funciona bien , no mola como le quieras llamar xD

    ResponderEliminar
  3. @Eduardo Sandoval ¿Porque lo estas ejecutando como root? esto no se ejecuta como root, si como usuario sin privilegios da el mismo error esto es mas un problema del gui, yo no he empaquetado esto, y no tengo acceso al src.rpm para revisar si fueron incluidas todas las dependencias previas a su ejecución.

    Intenta con esto.

    su -c 'yum -y install boost boost-python SDL'

    ResponderEliminar
  4. @David Va me dice que ya lo tengo instalado a la última versión.

    ResponderEliminar
  5. Me corrio muy bien, sobre fedora, muchas gracias por tu aporte.

    ResponderEliminar
  6. Alguien tiene un link efectivo para los ROMS?

    ResponderEliminar
    Respuestas
    1. www.coolrom.com
      es la mejor pagina que conozco de roms. pero casi todo esta en ingles

      Eliminar

Si comentas te pedimos por favor respeto y críticas constructivas referentes al título del articulo. Cualquier comentario para desviar el tema, spam o trolleo no será permitido. Gracias por comentar.