martes, 6 de mayo de 2014

Instala Skype en Fedora 32 y 64 bits! sin tanto problema...



Una de las mayores tonterias de Skype es pensar que en el mundo de las distribuciones 'rpm' solo existe i586, y con un software tan privativo, donde no puedes distribuirlo no puedes hacer absolutamente nada aunque tengas los conocimientos, recuerdo haber leido en su foro que alguien compartió el rpm para 64bits, dos años después no se tomo en cuenta el aporte...

Es por ello que, muchas veces se tiende a recurrir a instaladores que descargan y e instalan sin albergar nada del programa.

Esto no es malo, sin embargo yo soy de las personas que prefiere un rpm o deb para la arquitectura que tengo.

Alguien preguntaba por allí, "Quisiera instalar Skype en mi netbook pero la versión disponible es vieja, y ni siquiera corresponde a la misma arquitectura.
¿Hay alguna forma de actualizar ese paquete para que al menos coincidan las arquitecturas? Yo tengo una dual core. ¡¡Gracias!!"


La solución podría ser crear un nuevo rpm, pero usted gritará ¡no tengo los conocimientos para hacerlo"  venga el día de hoy le comparto un pequeño script que crea el rpm para usted a su arquitectura y lo instala, sin que usted toque nada del sistema. De manera que cuando usted quiera desinstalarlo, solamente tendrá que usar algún gestor de paquetes o yum.

Este script lo he creado también porque el nuevo PostInstallerF en desarrollo, no podía instalarlo desde repositorios de terceros por la no coincidencia de arquitecturas.

Bueno no los aburro mas :P


Desde una terminal... este script NO debe ejecutarse como root, solamente debe autenticarse cuando se lo solicite a la hora de instalar el rpm.





Reacciones:

5 comentarios:

  1. HOLA he probado tu script con el siguiente error,.

    => Building package
    skype-installer-4.2: línea 144: fpm: no se encontró la orden
    => Building done
    => Installing package
    Operación: Instalando archivos
    Estado: Finalizado
    Resultados:
    Error grave: could not resolve: /tmp/installdir/skype-4.2.0.13-1.fc20.x86_64.rpm
    => Installation completed

    ResponderEliminar
    Respuestas
    1. Este es un error de instalación de fmp, descarga nuevamente el script o desde una terminal SIN ser root 'gem install fpm', he modificado algunas lineas, mira mi pastebin, he borrado fmp para recrear el problema. este debería ser el resultado.

      http://pastebin.com/euNuYmNt

      Eliminar
  2. Respuestas
    1. Si, primero como otro proyecto 'skype-installer' y también como parte de PostInstallerF, para que exista colaboración :)
      En las próximas horas, necesito confirmar si alguien mas tuvo el problema anterior.

      Eliminar
  3. Te falto un '-' en el chmod y podrias poner todo en un solo renglon

    wget -O skype-installer-4.2 https://raw.githubusercontent.com/kuboosoft/skype-installer/master/skype-installer && chmod a+x skype-installer4.2

    ResponderEliminar

Si comentas te pedimos por favor respeto y críticas constructivas referentes al título del articulo. Cualquier comentario para desviar el tema, spam o trolleo no será permitido. Gracias por comentar.