jueves, 15 de enero de 2015

Freshplayerplugin la alternativa definitiva a Flash Plugin en Firefox, Ubuntu, Fedora, Arch Linux




Esto no es una sorpresa, los dias del flash-plugin están contandos.
Como usted sabe, Adobe ha suspendido el desarrollo de flash player plugin para GNU/Linux. Y la actual version que poseen los linuxeros es la "11.2.x", solamente funciona con NPAPI (utilizado solamente en Firefox) Adobe mantendrá actualizaciones de seguridad durante cinco años (desde su ultimo lanzamiento el 4 de mayo del 2012), o sea queda solamente un año de actualizaciones; si usted no lo ha notado un mayor desarrollo ha cesado en estos ultimos meses.

Por suerte o no (a su criterio), las nuevas versiones están y estarán disponibles para Linux (Versión hasta el momento 16.xx) solamente como parte del navegador Chrome, donde flash viene incluido como un PPAPI plugin. El API PPAPI o Pepper Plugin es una interfaz promovida por el equipo de Chrome, como parte sus plugins de navegador.

Por diversas razones, los desarrolladores de Firefox no están interesados ahora en la aplicación de PPAPI en Firefox. Sin embargo eso no significa que no se pueda hacer.

Sin aburrirlos, cuando desaparezca el flash-plugin no todo estará perdido ya que Rinat Ibragimov ha creado quizas lo imposible hasta el momento. ¡Poder usar pepper-flash sin problema en Firefox con freshplayerplugin!

El objetivo principal de este proyecto es conseguir PPAPI (Pepper) flash player que trabaje en Firefox. Esto se puede hacer de dos maneras. El primero es implementar la interfaz PPAPI por completo en Firefox. Otro es implementar, algún tipo de adaptacion que se verá como navegador para PPAPI plugin y parecerse a NPAPI plugin para el navegador.




Instalación


Ubuntu




Fedora

Si usted tiene el repositorio de PostInstallerF, basta solamente instalarlo con o yum/dnf o desde la interfaz gráfica de PostInstallerF




Arch Linux/Manjaro



sudo yaourt -S freshplayerplugin-git



Nota: 

Si usted utiliza otra distribución o el plugin no es detectado, cree un archivo de configuración indicando la ruta de "libpepflashplayer.so" con gedit o  su editor favorito.

gedit ~/.config/freshwrapper.conf

Agregue la siguiente linea reemplazando la ruta y guarde los cambios (no olvide incluir las comillas).

pepperflash_path = "/RUTA/PepperFlash/libpepflashplayer.so"


En Fedora u otras distribuciones es necesario desinstalar el flash-plugin para que no exista conflicto.
Reacciones:

6 comentarios:

  1. A mi me pasa que no me aparece la calidad de imagen, ni el sonido, ni nada, pero el vídeo se reproduce.
    Mira la imagen: http://imgur.com/G7b6wIT

    ResponderEliminar
    Respuestas
    1. Youtube y Firefox, presenta un problema con pepper, creo que es debido a la sobre exageración de la acelaracion y la reproduccion nativa. Lo que hago yo es deshabilitar flash solo en Youtube (porque alli es el problema) y en su lugar forzar el HTML5. Con este addon: https://addons.mozilla.org/es/firefox/addon/youtube-all-html5/?src=search

      Eliminar
  2. ¿Hay que tener instalado Google Chrome para que Flashplayer funcione en Firefox?

    ResponderEliminar
  3. Hola, en Fedora me da este error:

    # dnf -y install freshplayerplugin
    Última comprobación de caducidad de metadatos hecha hace 0:24:01, el Thu Jul 21 22:53:46 2016.
    Error: nothing provides ffmpeg needed by freshplayerplugin-0.3.5-5.20160428git99c5aa1.fc23.x86_64
    (pruebe a añadir '--allowerasing' a la línea de comandos para reemplazar los paquetes que producen conflictos)

    Qué será?

    ResponderEliminar
    Respuestas
    1. Pues alli mismo te esta diciendo el problema, no has instalado ffmpeg, disponible en rpmfusion...

      Eliminar

Si comentas te pedimos por favor respeto y críticas constructivas referentes al título del articulo. Cualquier comentario para desviar el tema, spam o trolleo no será permitido. Gracias por comentar.