jueves, 31 de enero de 2013

PostInstallerF 1.0.1 2013 ha salido!

 


PostInstallerF te ayuda con la autoinstalación de repositorios, así también la instalación de codecs y software adicional que el usuario final necesita , resolver algunos problemas, personalizar, proteger tu privacidad, información del sistema y mucho más con sólo unos clics en Fedora.






¿Nuevo en Fedora? ¿No sabes por donde empezar?


PostInstallerF es un menú que configura e instala los mejores programas de una manera sencilla e intuitiva para cualquier usuario en Fedora y Ubuntu.


En la actualidad existen algunas alternativas similares a PostInstallerF pero este se diferencia con las tareas básicas de un usuario novato o que venga de sistemas privativos y esté acostumbrado a tareas como, diseño, conversión y edición de video, navegación, mensajería etc.

Este programa esta hecho en bash, zenity y yad ¿Para que poner tanta dependencia?

PostInstallerF es un cúmulo de ideas que han surgido en la mayoría por problemas cotidianos, para darle solución de una manera simple. Aun le faltan algunas opciones que quisiéramos implementar a este extraordinario programa, y esta abierto a que cualquiera pueda colaborar (el proyecto necesita ser multilingue :/ ), cabe mencionar tiene una licencia libre y de código abierto cualquiera puede analizarlo y colaborar. El proyecto cuenta y es mantenido con dos colaboradores Kuboode y David Va; quienes en su tiempo libre (que es poco) le dedican un pequeño tiempo al proyecto (hobby).

Entre sus herramientas tenemos la instalación del llamado Multilanzer que pronto será incluido como parte interna de PostInstallerF, que nos facilita la tarea de crear lanzadores en Gnome Shell y el escritorio.







NOVEDADES DE ESTA VERSIÓN


  • Etamos emocionados, ahora PostInstallerF tiene rpm, listo para actualizar versiones obsoletas.
  • Compatible con Fedora 18
     
  • Steam, y se actualizará cuando salga a la luz la version final a principios de este año.
     
  • Netflix Player, un servicio de peliculas de pago.
  • Mejorado menu y dialogos.
  • Instalacion de codecs de audio y video
     
  • Instalación de controladores de video Ati y Nvidia (experimental, pero funcional, solo versión Fedora)
  • Instalación de Opera, Chrome, Chromium, Skype etc. Mas de 100 programas y modificaciones hara que tu experiencia sea mas que genial.
  • PostIstallerF está adaptada para el ya futuristico Gnome 3.6 y superiores donde tiene la opción de agregar extensiones del nuevo sitio de Gnome Shell Extensions. 
  • También incluyen juegos educativos y no tan educativos pensando en el usuario que le gusta jugar y los más pequeñitos. 
  • Funcional en LXDE, XFCE, KDE y GNOME, MATE y otros.
    Sigue el rasgo característico de la Navaja Suiza, incluye mejoras como autoactualización del programa por separado, lo que permite una actualizacion directa y mas rapida de cada elemento.
  • Eliminación de kernels antiguos sin dañar su SO, así también herramientas como "continuar instalaciones" donde muchas veces por algún error en el sistema, se nos ha ido la conexión de internet o un apagado repentino, este continua.
    Contiene clientes para Groveshark, Twiter, Facebook.


    Compatible con Fedora 16, 17 y 18





¿Cómo puedes colaborar?





Difundir y promocionar

¿Tenés un blog o sitio? ¿Administras algún grupo o fanpage de Facebook? ¿Tenés miles de seguidores en Twitter? Ayudar a que un proyecto open source se haga conocido es sumamente valorable, además, tu comunidad va a poder conocer nuevas herramientas de software que probablemente les sean de suma utilidad. Hay muchísima gente que no usa estos programas porque directamente desconoce su existencia, y es allí es donde tu puedes hacer algo para que eso cambie.




Contribuir con ideas o mejoras


Puedes enviarnos tus ideas o mejoras, por esta entrada; no les aseguramos implementarlas, todo depende de la viabilidad y factibilidad de lo que se propone.







INSTALACIÓN

Desde una terminal modo normal







FEDORA (Actualizado 31-01-2012)



su -c 'yum -y localinstall http://sourceforge.net/projects/postinstaller/files/Fedora%2018/postinstallerf-1.0.1-1.fc18.noarch.rpm'

Si usted tiene una version previa, por favor instale el nuevo rpm, este se encargara de actualizar la version anterior, internamente son cambios grandes, que las actualizaciones automaticas no lo pueden resolver al 100% por el momento.



¿Cómo desinstalarlo?



Ir a la opción de "Configure/Tuning" => "Desinstalar PostInstallerF" => OK








¿Qué se espera para el futuro?




  • Estamos analizando en que forma será implementado un desinstalador para todos los programas que instala PostInstallerF, tenemos 3 bocetos de ello. 


  • La migracion a un deb para la version final de Ubuntu

  • Mejoras en la interfaz.

  • Más configuraciones y programas.







Código Fuente

http://sourceforge.net/projects/postinstaller/files/srpm/postinstallerf-1.0.1-1.fc18.src.rpm





Como en todo lugar les pedimos respeto, esperamos críticas constructivas. gracias por utilizar PostInstallerF.

Reacciones:

21 comentarios:

  1. Creo que hay un error en la instalación para Ubuntu/Kubuntu y derivadas, pues luego de ejecutar "sudo sh postinstallerf.sh" aparece en la consola las siguientes 2 líneas finales: "isue =" y debajo "no es ubuntu".

    Busqué el ícono para probar y no lo encontré.

    Ahora... ¿cómo hago para aplicar la desinstalación que proponen?
    "Configure/Tuning" => "Desinstalar PostInstallerF" => OK"
    y también eliminar todo lo que me instaló y que no funciona.

    ResponderEliminar
  2. Se lee interesante. Yo lo instalé en Ubuntu con Unity sin ningun problema, al abrirlo me solicita contraseña de root y luego al ingresarla no hace nada, no aparece ninguna ventana, ni nada.
    ¿Faltará alguna dependencia?
    Gracias por tu respuesta David Va...

    ResponderEliminar
  3. Ya he logrado hacerlo funcionar, comento lo que sucedió por si a alguien más le sirve...
    Cuando se me solicitó la contraseña de root la primera vez yo no la había configurado (o no la conocía) entonces la dejé en blanco y al darle "aceptar" el programa se cerró. Luego definí (o cambié) la contraseña con "sudo passwd root", pero igualmente, aunque pusiera la nueva contraseña el programa siempre se cerraba.
    La solución fue volver a instalar el programa (reinstalarlo) y al colocar la contraseña desde un inicio ya funcionó.

    ResponderEliminar
  4. Recupero y Juan Carlos Carrillo Arriola.

    ¿Tienen Ubuntu 12.10? La versión para Ubuntu sera actualizada, pero necesito vuestra ayuda, por ejemplo mostrandome que les aparece desde una terminal lo siguiente:

    grep -e "Ubuntu" -e "Kubuntu" -e "Lubuntu" -e "Xubuntu" -e "Edubuntu" /etc/issue | awk '{print $1}'


    Y

    grep "Ubuntu" /etc/issue | awk '{print $1}'


    Creo que esta es la linea del problema, en Ubuntu 12.04 no había problema, al igual que Xubuntu 12.04.

    ------------------------------------

    Eduardo O:
    Muchas gracias por compartir, como tu decías lo de la contraseña, como todo programa que necesita privilegios administrativos, necesita de tu contraseña administrativa en el caso de Ubuntu de "sudo"

    ResponderEliminar
  5. Uso Mint Nadia KDE x64.
    Hice lo que pides en una terminal y no aparece nada, una pena no se como colocarte una captura de pantalla, pero al escribir tal cual colocaste no sale ninguna orden solo:
    "mi nombre@mi máquina ~ $"
    Gracias por la aplicación, pero por ahora prefiero seguir usando Synaptic.
    Te deseo lo pulas bien y te salga estupendo.

    ResponderEliminar
  6. Desearía herramientas de KDe por este genial medio "calligra, Kolourpaint, Marble, Okular, Konqueror, Owncloud, Kdevelop"
    herramientas de programacion "Lazarus, Monodevelop, Kdevelop, Aljuta y Glade.
    También que la instalación de LibreOffice sea más reciente y complata "flata Base y Math" y tambien desearia Sodipodi, Kturtle, Cinelerra, que actalizaen los programas como mmc y que Openshot instalado via postinstallef no se cuelge y tambien desearia Kino
    muchas gracias

    ResponderEliminar
  7. Recupero Ghermain: PostInstallerF no funciona en Linux Mint, pero puede solucionarse, agregando una simple linea se soluciona, pero como no uso Mint, no tengo la información que necesito:

    Si pueden dar una mano, ya podria utilizarse en Linux Mint ¿Que necesito?

    copy y paste de lo que contiene el siguiente archivo:


    /etc/issue


    El archivo anterior es propio de la mayoría de distribuciones y de la cual puede lograr identificar lo que se esta utilizando.

    ResponderEliminar
  8. Conejito Ggonzalez:

    Estamos en eso, ya hemos logrado empaquetar Mobil Media Converter ( mmc) en 32 bits y otros puedes revisar la siguiente guia: http://kuboosoft.blogspot.com/2012/12/que-hacer-despues-de-instalar-fedora-18.html

    Openshot, esta fuera de mis manos, y depende de los desarrolladores, te recomiendo Kdenlive.

    Respecto a Kino, he intentado compilarlo, pero el problema son las dependencias, no quiero darte falsas esperanzas pero llevo mucho tiempo de tratar de correrlo bien y funciona muy mal, es inestable.

    Veo varios nombres de programas que no habia escuchado, si se puede incluir, pues sera una de las novedades junto con el lanzamiento del "rpm" de PostInstallerF :)

    ResponderEliminar
  9. Gracias,
    pero desearia saber porque mi Scribus se come las tildes y a veces no muestra las imagenes

    ResponderEliminar
  10. David Va si quieres te paso algunos d los RPMs de esos software,
    solo pidemelos

    ResponderEliminar
  11. Gatoloco65, estamos restructurando internamente, PostInstallerF fue contruido para la version LTS de Ubuntu 12.04, aun no entiendo porque optan por versiones intermedias.

    ResponderEliminar
  12. Me pregunto donde conseguir el rpm o 1 portable por lo menos de ELLA
    http://ella.tuxfamily.org/wiki/Main_Page

    ResponderEliminar
  13. desconocia de ella, si puedo crear un rpm lo compartire, estamos muy ocupados estos dias. Trata de compilarlo y nos informas.

    ResponderEliminar
  14. Ok
    y dime tu conecoes alguna alternativa al sencha o adeobe edge para Fedora?
    un portable como transcoder "extraiga y ejecute"
    o un rpm?

    ResponderEliminar
  15. Conejito Ggonzalez: tristemente no, ni sabia sobre sencha, escribe bien para que todos te entiendan, procura utilizar un mismo espacio para preguntar, ya te pudiste dar cuenta en el grupo de google, no tengo mucha experiencia en html5, pero en el blog de xenode o grupo pueden ayurde, no abuses, no todos son tolerantes y te va a suceder lo mismo.

    ResponderEliminar
  16. Kuboode David Va les cuento que tengo 1 rpm de cinelerra actualizado
    y de BasKet
    te lo paso y los inclouimnos en Postinstallerf
    ambos
    son útiles buenos y funcionales

    ResponderEliminar
  17. aqui te los paso:

    Cinelerra:
    * http://www.wuala.com/Alvinalosaurio/app/cinelerra-2.0-1.i386.rpm/

    gimp-gap
    * http://www.wuala.com/Alvinalosaurio/app/gimp-gap-2.0.2-1.i386.rpm/

    BasKet:
    * http://www.wuala.com/Alvinalosaurio/app/basket-1.0.3.1-8.el6.i686.rpm/

    Knowit:
    * http://www.wuala.com/Alvinalosaurio/app/knowit-0.10-2.el4.rf.i386.rpm/

    Knotes:
    * http://www.wuala.com/Alvinalosaurio/app/knotes-3.0.5a-1.i386.rpm/

    ResponderEliminar
  18. Please look into this google-earth packaging bug,
    https://sourceforge.net/p/postinstaller/discussion/general/thread/22ddc07f

    thanks.

    ResponderEliminar
    Respuestas
    1. Thanks, The next 24 hours I will update the package, thanks for report it. :)

      Eliminar

Si comentas te pedimos por favor respeto y críticas constructivas referentes al título del articulo. Cualquier comentario para desviar el tema, spam o trolleo no será permitido. Gracias por comentar.